HData - Library Catalog Search Degradation – Incident details

Library Catalog Search Degradation

Resolved
Major outage
Started 4 days agoLasted about 3 hours

Affected

Overall

Major outage from 1:02 PM to 3:26 PM, Partial outage from 1:02 PM to 12:00 AM

Library

Major outage from 1:02 PM to 3:26 PM, Partial outage from 3:26 PM to 12:00 AM

Platform

Partial outage from 1:02 PM to 12:00 AM

Updates
  • Resolved
    Resolved

    The OpenSearch clusters have now recovered, no errors have been detected for the last 18 minutes, and our QA team has confirmed that Library and Search are functioning normally. The issue is now resolved. Our apologies for any inconvenience caused.

  • Monitoring
    Monitoring

    The cluster is recovering, and 75% of shards are now assigned. Search functionality is steadily recovering, and error rates are dropping.

  • Identified
    Identified

    The team was made aware of a performance issue on our OpenSearch clusters, which is responsible for the search capabilities of many of our Catalog datasets. The issue has been identified and the team is working to resolve.