Started over 1 year agoApril 17, 2025Lasted about 3 hoursApril 17, 20254:387:23 PMUTC
Updates
Resolved
UTC
Resolved
UTC
The rollback completed, and testing shows that the incident is now resolved. Our apologies for any inconvenience caused.
Identified
UTC
Identified
UTC
The root cause was identified as a security library update in the recent deployment. It will take several hours to resolve going that route, so the team is proceeding with a rollback to resolve the issue.
Investigating
UTC
Investigating
UTC
User permissions are not associating correctly with Compliance usernames after a recent change. Many customers are unable to complete FERC filings as a result. The team is investigating the root cause.